This project is read-only.

AdRotator-Beginner struggling with Unity

Feb 28, 2014 at 5:21 PM
Edited Feb 28, 2014 at 5:49 PM
I just stumbled over AdRotator and am really looking forward to using it with Unity3D (Windows Phone 8 Project)
I set up my existing project by following the steps (from AdRotator v2 Unity Support Site)
  • Imported to Unity
  • Set up the XML for PubCenter, AdMob and AdDuplex
  • Added the Controller to my Szene (first element in hirarchy)
  • Built my App and importet AdRotator v2 (Prerelease)
  • Importet dlls for Pubcenter, AdMob and AdDuplex
Right now I get the error, that the AdRotatorUnitySDK doesn't have a definition for Assets and I'm not sure how to handle this. The errors occure in the AdRotatorBridge. The only avaiable Namespace in the AdRotatorUnitySDK is integration.

Thank you!

EDIT: One basic question would be: Do I have to follow the instructions in the ReadMe- File, as there is no reference to those steps in the description on the WebPage (Unity Support Site by AdRotator -> UnitySupportSite
Feb 28, 2014 at 6:09 PM
The readme in the Nuget package is a generic helper file, we've not updated that yet to include unity docs.

I'll test this again tonight to ensure we've not missed something in the docs, a couple of things, to check.

• can you replicate the error in a blank project
• have you checked all the providers you are using work on your target platform (admob doesn't work on wp8 last I heard)
• have you tried just one provider (say adduplex b/c it's the simpliest) to check if its a provider / config issue or the adrotator unity component

hope we have an answer soon
Feb 28, 2014 at 6:23 PM
I'll try that. One quick thing: AdMob does provide WP8 dlls AdMob WP8
Feb 28, 2014 at 7:00 PM
😎 oh I know they provide them but I've not heard of anyone who has actually got them to work. Unless its been updated since last I checked
Mar 1, 2014 at 12:16 PM
Edited Mar 1, 2014 at 2:29 PM
So I tried to structure the problem a little, here's what I did and how it turned out:
  • I used my current project in a "clean" (no AdRotator) way, built it and it worked fine.
  • SetUp AdRotator for AdDuplex only. Question: Should the Win8 Config Files be removed from the assets folder when the project is WP8 only?
  • Added the AdRotatorManager to my Scenes - being the first one in the hierarchy and starting with the first and every following scene of my game - default AdProvider set to AdDuplex.
  • Tried Build & Run in Unity 3d -> "Exception: failed to build Visual Studio Project" (could provide the whole message, if helpful).
  • Tried Build only, which works.
  • Opening the Visual Studio Solution - Importet AdRotator (PreRelease 2.1.0 Beta) including AdDuplex
  • Buidling the Solution throws an Error in MainPage.xaml.cs -> Two identical Functions "void ExecuteOnUIThread(Delegate todo). One function is being added each build! I removed one of the functions and Build again -> success; The additional functions are being added again everytime I build with unity.
  • Running Game works for some time, even showing an AdDuplex Ad, but after some seconds: NullReferenceException at AdRotator.AdRotatorControl.Dispose() and System.Reflection.TargetInvocationException (it seems that a DebugBuild crashes a little earlier).
If you need any further information just let me know. Hope this helps.
Mar 12, 2014 at 7:30 AM
Did you have the time to look into this issue? I don't want to bug you, AdRotator is just one of the things I would like to do before calling my app finished =)
Thank you!
Mar 24, 2014 at 9:17 AM
Many apologies, work ramped up and I didn't get a chance to look into this.

Planning to get some testing done today, so fingers crossed.