This project is read-only.

Initial release doubts

Jun 18, 2013 at 11:12 AM
Edited Jun 18, 2013 at 11:13 AM
Hello there, and first of all thanks for the nice work. It really helps a lot.

I am trying to use adrotator v2 in my Windows 8 and WinRT project and I have some doubts.
Does a sample on how to use it exists?

First of all, the size of the ad doesn't seems to do anything. In the previous version it worked well but in this version I always get the Adduplex square, although I choose different sizes on the Xaml.

IsTest on the Xaml or code always throws a invalid cast exception.

Also.. Do I have to manually include the dlls for InMobi and PubCenter since it only brings the AdDuplex ones?

Thanks in advance, and once again congratulations on the great work
Jun 28, 2013 at 12:07 AM
Weve included docs on the new site for the v2 release but if youre familiar with v1 its use is the same but with new config

Yes you need to include dlls for the probviders you want tonuse but you no longer need to add them all, just the ones youre using.

Adsizes should come through and istest didn't cause issue in our original testing but we
ll check into that. Be surento use the values for the adsizes as per the provider spec, usually if you get it wrong then they will give you the default, were hoping to abstract this in the future with an ad size type

Be sure to let us know how you get on with the alpha
Jul 15, 2013 at 8:02 AM
OK, I've managed to replicate the "isTest" issue, not sure what is going on there but will have a look at it for the next drop. For now just don't use it.
Aug 8, 2013 at 2:18 PM
I'd like to point out I'm having this same problem. I got adrotator through nuget, and AdDuplex is always sending me 250x250 ads for a 728x90 banner. It still displays, but just . . . clips the lower two thirds of the ad off.
Aug 8, 2013 at 2:54 PM
We did try several of the official ad sizes from each provider. Have you tried this in the test app?

Also if you use the AdDuplex control manuall does it cause the same effect?
Aug 12, 2013 at 12:14 AM
Withe the AdDuplex control manually added I don't have that problem.
Sep 12, 2013 at 10:36 AM
Should be sorted in the 2.02 alpha release now, let us know how you get on