This project is read-only.

I cannot for the life of me get V2 to work via dll or compiling it myself.

Jul 14, 2013 at 7:32 AM
If I use the dll then my windows 8 store app crashes with:

System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Threading.Tasks, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
at AdRotator.AdRotatorComponent.GetConfig()
at AdRotator.AdRotatorControl.AdRotatorControl_Loaded(Object sender, RoutedEventArgs e)

If I try to compile the code (in a portable or non portable project) then I get 35 errors due to many reflection and delegate functions not existing.

What am I doing wrong?
Jul 14, 2013 at 12:43 PM
How are you installing adrotator?
  • if you install from nuget then everything is setup for you
  • if you install from source then you will need to enable nuget package restore and then after building, copy over all the dependent dlls
Nuget now uses a pcl solution at its core and the Microsoft bcl libraries to enable async on all platforms

hope that helps

our recommendation if you are jus adding it to your project is to install the nuget package, as its an alpha at present be sure to use the -pre or "include prerelease" options
Jul 15, 2013 at 1:49 AM
The first way I said was using nuget to integrate the librarys.

that gave me the top error.
Jul 15, 2013 at 7:46 AM
Edited Jul 15, 2013 at 7:47 AM
Ok, I didn't get you were using NuGet from "using the dll"

what environment are you using to build your solution?
will test out the nuget again to see if something has gone awry since it was published.

in vs2012 you shouldn't need anything, with vs2010 you'll need both the portable libraries and async extensions (if that's your issue I'll update the docs)
*edit, lol your doing a win 8 app so you must be using vs2012,lol
Jul 15, 2013 at 7:59 AM
Right, I just tested the Win 8 NuGet release without issue, heres the steps I did.

1: started new Win 8 blank app project
2: Right clicked references and selected "Manage NuGet Packages"
3: Selected the "include pre release option"
4: Searched for "AdRotator"
5: Installed the 2.0.0-Alpha version
6: Accepted the license for the Microsoft BCL libraries
7: Copied the XAML from the readme.txt to MainPage.xaml
8: copied the namespace from the readme to the XAML
9: run

And was presented with an AnDuplex ad (which is the default installed provider

Hope this helps.
Sep 26, 2013 at 8:11 AM
Edited Sep 26, 2013 at 8:28 AM
I have tried using my colleague's system which has Windows 8 Pro 64Bit and we ran a project Visual Studio 2012 Express for Windows Phone, we also tried a XNA game project which yielded the same error. However when we created a XAML C# App Project it worked.

Will AdRotator work with XNA projects?

Hey Simon,
I was trying to install AdRotator V1.0.3 from NuGet into my Windows Phone 7.1 XNA Project.
I am using Visual Studio 2010 Express for Windows Phone and I have Windows 7 Pro 64-Bit.

I am getting this error when I am try to install via PowerShell.

Installing 'AdRotatorWP 1.0.3'.
Successfully installed 'AdRotatorWP 1.0.3'.
Adding 'AdRotatorWP 1.0.3' to WindowsPhoneGame1.
Uninstalling 'AdRotatorWP 1.0.3'.
Successfully uninstalled 'AdRotatorWP 1.0.3'.
Install failed. Rolling back...
Install-Package : Could not install package 'AdRotatorWP 1.0.3'. You are trying to install this p
ackage into a project that targets '.NETFramework,Version=v4.0,Profile=Client', but the package d
oes not contain any assembly references or content files that are compatible with that framework.
For more information, contact the package author.
At line:1 char:16
  • Install-Package <<<< AdRotatorWP
    • CategoryInfo : NotSpecified: (:) [Install-Package], InvalidOperationException
    • FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPac
What do I have to do to get it working?

Thanks in advance,
Stanley J. Maliackal
Nextwave Multimedia.
Sep 26, 2013 at 11:03 AM
Ahh, I see one problem there:
I was trying to install AdRotator V1.0.3 from NuGet into my Windows Phone 7.1 XNA Project.

V2 does not yet support XNA sadly.

You can use it with MonoGame WP projects on WP8 if you need an XNA like experience.
For WP7 XNA projects you will still have to use V1 I'm afraid (although just finishing up an update to that at the moment)
Sep 26, 2013 at 12:15 PM
Hey Simon,
So, adrotator may soon support XNA or is it off the pipeline?

Stanley J. Maliackal
Nextwave Multimedia.
Sep 27, 2013 at 6:51 PM
It's still in our roadmap at the moment, adding it to V1 was a major undertaking as most proviers had to be written from the ground up using WebAPI interfaces. We are still planning on WebWPI support so XNA will follow suit. We are also tightly coupled with MonoGame so we want to be able to support them from both an XNA and Mono perspective.

Also note we just released a beta for @Unity3D for V1 as well, which will be coming to V2 plus a fully integrated version (we hope) later.

Just time that's all :D